Back

CVE-2014-0130

HIGH CISA KEV

Directory traversal vulnerability in actionpack/lib/abstract_controller/base.rb in the implicit-render implementation in Ruby on Rails before 3.2.18, 4.0.x before 4.0.5, and 4.1.x before 4.1.1, when certain route globbing configurations are enabled, allows remote attackers to read arbitrary files via a crafted request.

Published: May 7, 2014 Modified: Jun 17, 2026
CWE-22 CWE-22

CVSS Metrics

CVSSv3
Attack Vector: NETWORK Attack Complexity: LOW Privileges Required: NONE User Interaction: NONE Scope: UNCHANGED Confidentiality Impact: HIGH Integrity Impact: NONE Availability Impact: NONE

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected Products (5)

Vendor Product Version
redhat subscription_asset_manager *
redhat enterprise_linux_server 6.0
rubyonrails rails * < 3.2.18
rubyonrails rails * ≥ 4.0.0 < 4.0.5
rubyonrails rails * ≥ 4.1.0 < 4.1.1

GitHub Security Advisory GHSA-6x85-j5j2-27jx

actionpack Path Traversal vulnerability

rubygems actionpack >= 3.0.0, < 3.2.18 Fixed: 3.2.18
rubygems actionpack >= 4.0.0, < 4.0.5 Fixed: 4.0.5
rubygems actionpack >= 4.1.0, < 4.1.1 Fixed: 4.1.1

Risk Scores

CVSS Score 7.5 / 10
EPSS Score 53.70%

Top 1% most likely to be exploited

Threat Score 76.1 / 100

CISA Known Exploited

Date Added: 2022-03-25
Due Date: 2022-04-15
Required Action:

Apply updates per vendor instructions.

Data Sources

NVD CISA KEV EPSS GitHub